Fixing the Firefox “…due to mozilla’s security features error” pop-up

I upgraded to the most recent version of Firefox, and for awhile, I was getting a “…due to mozilla’s security features” pop-up error on a lot of websites I visited.

I found the solution to get rid of this highly annoying “feature” from a user named Castaign buried in the Firefox forum.

“This is likely caused by the Web Fixer add on. If you have this add on installed, you should have a small icon on the bottom right corner of Firefox (next to the authentication padlock icon) that says Fix. Click this to access the Web Fixer menu and choose Quick Settings –> Change Settings –> Other Options tab. Uncheck the box labeled “Show message on security errors”. You may need to restart Firefox for the fix to work.”

Thanks Castaign!

One thought on “Fixing the Firefox “…due to mozilla’s security features error” pop-up

Leave a Reply

Your email address will not be published. Required fields are marked *